Error in auto-translate

Sep 18, 2013 at 8:08 PM
I have a DNN site rel. 07:00:06, in Italian, translated into other 4 languages: English, French, German and Spanish.
I installed CLTools rel. 1.0.0 to facilitate the translation.
I created an account in the Windows Azure Marketplace, and I modified my web.config with ClientId and ClientSecret.
When I try CLTOOLS, it displays this error:
Http status code=ProtocolError, error message={"error":"invalid_client","error_description":"ACS50012: Authentication failed.\r\nTrace ID: dd090504-4fa7-4924-a462-0dee434a06c4\r\nCorrelation ID: 3824bfa6-d9af-476a-9e05-23c4e52a0193\r\nTimestamp: 2013-09-18 19:07:13Z"}
What should I do?
Your look, thanks
Coordinator
Sep 19, 2013 at 5:47 PM
Hi,

I just test the auto translation on my website.
It work fine.

I think it's a configuration on Windows Azure Marketplace.

Regards,
Sacha
Sep 20, 2013 at 8:21 AM
Ok, I deleted and re-configuration of the Windows Azure Marketplace.
Now it works.

I checked out another problem.
In a page I have about 20 HTML modules.
To work the translation of all the modules together displays the error: ArgumentOutOfRangeException: the parameter 'texts' must be less than '10241' characters Parameter name: texts: ID = 3010.V2_Soap.TranslateArray.346843E9.
If the translation process it one by one, works well.

What should I do?
Your look, thanks
Coordinator
Sep 20, 2013 at 9:34 AM
Hi,

I know about this problem.
The problem is that you have a limited free request to the microsoft translation service.
So a try to make one request with all the things to translate on the page.
If this is to big i have to split it up in different requests.

I will modify this. But i don't think to have time to this this month.

Regards,
Sacha
Coordinator
Sep 20, 2013 at 9:35 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Sep 21, 2013 at 7:02 AM
Ok, so look forward to the new version.
Thank you.